[Ubuntu 9.10] Instalar Netbeans con soporte para J2ME (y emulador)

Para instalar Netbeans en Ubuntu, nada más fácil. Id al centro de software de ubuntu y buscar "Netbeans".


Una vez instalado, hay que instalar los plugins "Mobility". Id al menu "Plugins" y en la pestaña "Avaiable plugins" seleccionar los dos plugins de mobility.




Una vez instalados los plugins, tenemos que instalar el "sun_java_wireless_toolkit" Será necesario para poder programar para dispositivos móviles. El paquete adjunta, entre otros, el emulador y los ejemplos de código necesarios para poder empezar. Pulsa aquí para descargarlo. Si el enlace no funciona, por favor, notifícalo.

Se descargará en formato binario, como viene siendo habitual. Le damos permiso de ejecución.





Después lo ejecutamos:


Entonces se abrirá la terminal y nos mostrará el contrato de licencia. Pulsamos la tecla "q" y se nos preguntará [yes|no]. Escribiremos "yes".

 



Nos preguntará si deseamos ecribir la ruta de acceso al interprete de java. Pulsamos 0. En ubuntu, la ruta que deberíamos incluir sería ésta:

/usr/lib/jvm/java-6-sun/bin/

 Después nos pedirá la ruta de instalación del paquete. Podemos dejarlo en

/home/usuario/wtk
 Seguidamente nos preguntará si queremos buscar actualizaciones del software. Podemos escribir "yes" o "no". Para finalizar la instalación, pulsaremos "0".




 Ahora, tenemos que añadir el pauqte en netbeans. Vamos al menú "Tools -> Java Platforms". Hacemos click en "Add platform".


Seleccionaremos la plataforma Java ME MIDP. Click en "Next".


 
Seleccionaremos el directorio donde instalamos el Wireless Toolkit. Hacemos click en aceptar y luego finalizamos el asistente.

Listo. Ahora ya podemos abrir un nuevo proyecto para MIDP. Si necesitas unas guías para empezar a programar para la plataforma, puedes empezar por éstos links:

Y como siempre, puedes contactar con nosotros en:

9 comentarios:

diego dijo...

hola gracias por su exelente aporte ... tengo un problema al momento de instalar el "sun_java_wireless_toolkit", sigo los pasos tal cual dice y al darle en la última opción "0" dice "checksumming ..." luego aparece "Extracting installation files..." y en ese preciso instante se cierra la ventana de la consola.... tiene alguna idea que problema puede ser? agradezco la colaboración !

diego dijo...

bueeno... lo resolví sin problemas, era un simple problema de ejecutar como super usuario ... por eso algunas veces prefiero hacerlo todo desde allí... por lo demás FELICITACIONES por este excelente artículo, gracias nuevamente

k-len dijo...

Exelente aporte man, buenisimo lo que andaba buscando y no podia encontrar, se te agradece

cristian dijo...

tengo un problemita... instale en jdk 1.6.0_19 y cuando quiero instalar el wireless toolkit, le indico que esta instalado el jdk en /usr/java/jdk1.6.0_19/bin (si, esta ahi!) pero me aparece un error que dice "not a suitable java interpreter" >:(
que hice mal? lo instale lo mas bien en windows, pero tambien lo quiero usar en linux!! espero me puedan ayudar. gracias saludos

cristian.dc@hotmail.es

gmg dijo...

Muchas gracias!! me ha servido de mucho!!
Saludos!

Santiago dijo...

Muchísimas gracias, me sirvió pila.

Anónimo dijo...

Hola diego el enlace me envia a otra pagina en oracle por favor monta un enlace bueno te lo agradeceria

Daniel Perella dijo...

Enlace ahora apunta bien:

http://www.oracle.com/technetwork/java/download-135801.html

Gracias

Julio Morillo dijo...

Al fin algo bien hecho, me a ayudado mucho, gracias.!!!